CVEvulnerability
CVE-2023-6848
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2023-12-16
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.3 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 2.0 ([email protected])
- 7.5 HIGH — AV:N/AC:L/Au:N/C:P/I:P/A:P
- Weaknesses
- CWE-77
Description
A vulnerability was found in kalcaddle kodbox up to 1.48. It has been declared as critical. Affected by this vulnerability is the function check of the file plugins/officeViewer/controller/libreOffice/index.class.php. The manipulation of the argument soffice leads to command injection. The attack can be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.48.04 is able to address this issue. The identifier of the patch is 63a4d5708d210f119c24afd941d01a943e25334c. It is recommended to upgrade the affected component. The identifier VDB-248209 was assigned to this vulnerability.
Affected configurations
• kodcloud kodbox (< 1.48.04)
Related
Weakness · CWE (1)
- CWE-77 Improper Neutralization of Special Elements used in a Command weakness
References
- https://github.com/kalcaddle/kodbox/commit/63a4d5708d210f119c24afd941d01a943e25334c Patch
- https://github.com/kalcaddle/kodbox/releases/tag/1.48.04 Release Notes
- https://note.zhaoj.in/share/pf838kAzQyTQ Permissions Required
- https://vuldb.com/?ctiid.248209 Permissions Required, Third Party Advisory
- https://vuldb.com/?id.248209 Third Party Advisory
- https://github.com/kalcaddle/kodbox/commit/63a4d5708d210f119c24afd941d01a943e25334c Patch
- https://github.com/kalcaddle/kodbox/releases/tag/1.48.04 Release Notes
- https://note.zhaoj.in/share/pf838kAzQyTQ Permissions Required
- https://vuldb.com/?ctiid.248209 Permissions Required, Third Party Advisory
- https://vuldb.com/?id.248209 Third Party Advisory