CVEvulnerability

CVE-2024-0507

8.8 HIGH Published 2024-01-16 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2024-01-16
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:N
CVSS 3.1 ([email protected])
8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-20, CWE-77

Description

An attacker with access to a Management Console user account with the editor role could escalate privileges through a command injection vulnerability in the Management Console. This vulnerability affected all versions of GitHub Enterprise Server and was fixed in versions 3.11.3, 3.10.5, 3.9.8, and 3.8.13 This vulnerability was reported via the GitHub Bug Bounty program.

Affected configurations

• github enterprise server (< 3.8.13) • github enterprise server (>= 3.9.0 < 3.9.8) • github enterprise server (>= 3.10.0 < 3.10.5) • github enterprise server (>= 3.11.0 < 3.11.3)

Related

Weakness · CWE (2)

  • CWE-20 Improper Input Validation weakness
  • CWE-77 Improper Neutralization of Special Elements used in a Command weakness

References