CVEvulnerability
CVE-2024-13910
7.2 HIGH
Official page ↗
- Status
- Deferred
- Published
- 2025-03-01
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.2 HIGH — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-22
Description
The Database Backup and check Tables Automated With Scheduler 2024 plugin for WordPress is vulnerable to arbitrary file deletion due to insufficient file path validation in the 'database_backup_ajax_delete' function in all versions up to, and including, 2.35. This makes it possible for authenticated attackers, with Administrator-level access and above, to delete arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php). The vulnerability was partially patched in version 2.36.
Related
Weakness · CWE (1)
- CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness
References
- https://plugins.trac.wordpress.org/browser/database-backup/trunk/database-backup.php#L267 plugins.trac.wordpress.org
- https://plugins.trac.wordpress.org/changeset/3247917/ plugins.trac.wordpress.org
- https://plugins.trac.wordpress.org/changeset/3248708/ plugins.trac.wordpress.org
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c92776c4-643c-40f2-ac28-5df5d6bf7fcd?source=cve www.wordfence.com