CVEvulnerability
CVE-2024-14042
2.1 LOW
Official page ↗
- Status
- Deferred
- Published
- 2026-08-11
- Last modified
- 2026-10-27
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 2.1 LOW — CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 6.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- CVSS 2.0 ([email protected])
- 6.5 MEDIUM — AV:N/AC:L/Au:S/C:P/I:P/A:P
- Weaknesses
- CWE-119, CWE-121
Description
A vulnerability was found in Open5GS up to 2.7.1. This affects the function hss_ogs_diam_s6a_air_cb/hss_ogs_diam_s6a_ulr_cb of the file src/hss/hss-s6a-path.c of the component Diameter S6a Interface. Performing a manipulation of the argument os.len results in stack-based buffer overflow. It is possible to initiate the attack remotely. The exploit has been made public and could be used. Upgrading to version 2.7.2 is able to mitigate this issue. The patch is named e89aa79efe629ae90f59dcdf8847c117d9a7da86. It is suggested to upgrade the affected component.
Related
References
- https://github.com/open5gs/open5gs/ github.com
- https://github.com/open5gs/open5gs/commit/e89aa79efe629ae90f59dcdf8847c117d9a7da86 github.com
- https://github.com/open5gs/open5gs/files/15051218/capture.pcap.gz github.com
- https://github.com/open5gs/open5gs/issues/3155 github.com
- https://github.com/open5gs/open5gs/releases/tag/v2.7.2 github.com
- https://vuldb.com/cve/CVE-2024-14042 vuldb.com
- https://vuldb.com/submit/867105 vuldb.com
- https://vuldb.com/vuln/387280 vuldb.com
- https://vuldb.com/vuln/387280/cti vuldb.com