CVEvulnerability
CVE-2024-14044
2.1 LOW
Official page ↗
- Status
- Deferred
- Published
- 2026-08-12
- Last modified
- 2026-10-01
- Assigner
- [email protected]
- CVSS 4.0 ([email protected])
- 2.1 LOW — CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVSS 3.1 ([email protected])
- 6.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- CVSS 2.0 ([email protected])
- 6.5 MEDIUM — AV:N/AC:L/Au:S/C:P/I:P/A:P
- Weaknesses
- CWE-119, CWE-120
Description
A vulnerability was identified in Open5GS up to 2.7.1. This issue affects the function pcrf_rx_aar_cb of the file src/pcrf/pcrf-rx-path.c of the component Diameter Rx Handler. The manipulation of the argument num_of_media_component/num_of_sub leads to buffer overflow. The attack can be initiated remotely. The exploit is publicly available and might be used. Upgrading to version 2.7.2 is capable of addressing this issue. The identifier of the patch is 87b4e4535c77ded627cdb6f4e4e2e3ea761f40b7. It is recommended to upgrade the affected component.
Related
References
- https://github.com/open5gs/open5gs/ github.com
- https://github.com/open5gs/open5gs/commit/87b4e4535c77ded627cdb6f4e4e2e3ea761f40b7 github.com
- https://github.com/open5gs/open5gs/files/15051247/capture.pcap.gz github.com
- https://github.com/open5gs/open5gs/issues/3157 github.com
- https://github.com/open5gs/open5gs/releases/tag/v2.7.2 github.com
- https://vuldb.com/cve/CVE-2024-14044 vuldb.com
- https://vuldb.com/submit/867117 vuldb.com
- https://vuldb.com/vuln/387282 vuldb.com
- https://vuldb.com/vuln/387282/cti vuldb.com