CVEvulnerability

CVE-2024-1735

9.1 CRITICAL Published 2024-02-26 Modified 2026-06-17 Official page ↗
Status
Analyzed
Published
2024-02-26
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-287

Description

A vulnerability has been identified in armeria-saml versions less than 1.27.2, allowing the use of malicious SAML messages to bypass authentication. All users who rely on armeria-saml older than version 1.27.2 must upgrade to 1.27.2 or later.

Affected configurations

• linecorp armeria (< 1.27.2)

Related

Weakness · CWE (1)

  • CWE-287 Improper Authentication weakness

References