CVEvulnerability
CVE-2024-21647
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2024-01-08
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.9 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-444
Description
Puma is a web server for Ruby/Rack applications built for parallelism. Prior to version 6.4.2, puma exhibited incorrect behavior when parsing chunked transfer encoding bodies in a way that allowed HTTP request smuggling. Fixed versions limits the size of chunk extensions. Without this limit, an attacker could cause unbounded resource (CPU, network bandwidth) consumption. This vulnerability has been fixed in versions 6.4.2 and 5.6.8.
Affected configurations
• puma puma (< 5.6.8)
• puma puma (>= 6.0.0 < 6.4.2)
Related
Weakness · CWE (1)
- CWE-444 Inconsistent Interpretation of HTTP Requests weakness
References
- https://github.com/puma/puma/commit/5fc43d73b6ff193325e657a24ed76dec79133e93 Patch
- https://github.com/puma/puma/security/advisories/GHSA-c2f4-cvqm-65w2 Vendor Advisory
- https://github.com/puma/puma/commit/5fc43d73b6ff193325e657a24ed76dec79133e93 Patch
- https://github.com/puma/puma/security/advisories/GHSA-c2f4-cvqm-65w2 Vendor Advisory
- https://lists.debian.org/debian-lts-announce/2024/11/msg00004.html lists.debian.org