CVEvulnerability

CVE-2024-21690

8.2 HIGH Published 2024-08-21 Modified 2026-06-17 Official page ↗
Status
Analyzed
Published
2024-08-21
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
8.2 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:L/A:N
CVSS 3.0 ([email protected])
7.1 HIGH — CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:N
Weaknesses
CWE-79

Description

This High severity Reflected XSS and CSRF (Cross-Site Request Forgery) vulnerability was introduced in versions 7.19.0, 7.20.0, 8.0.0, 8.1.0, 8.2.0, 8.3.0, 8.4.0, 8.5.0, 8.6.0, 8.7.1, 8.8.0, and 8.9.0 of Confluence Data Center and Server. This Reflected XSS and CSRF (Cross-Site Request Forgery) vulnerability, with a CVSS Score of 7.1, allows an unauthenticated attacker to execute arbitrary HTML or JavaScript code on a victims browser and force a end user to execute unwanted actions on a web application in which they're currently authenticated which has high impact to confidentiality, low impact to integrity, no impact to availability, and requires user interaction. Atlassian recommends that Confluence Data Center and Server customers upgrade to latest version, if you are unable to do so, upgrade your instance to one of the specified supported fixed versions: * Confluence Data Center and Server 7.19: Upgrade to a release greater than or equal to 7.19.26 * Confluence Data Center and Server 8.5: Upgrade to a release greater than or equal to 8.5.14 * Confluence Data Center and Server 9.0: Upgrade to a release greater than or equal to 9.0.1 See the release notes (https://confluence.atlassian.com/doc/confluence-release-notes-327.html). You can download the latest version of Confluence Data Center and Server from the download center (https://www.atlassian.com/software/confluence/download-archives). This vulnerability was reported via our Bug Bounty program.

Affected configurations

• atlassian confluence data center (>= 7.19.0 <= 7.19.25) • atlassian confluence data center (>= 7.20.0 <= 7.20.3) • atlassian confluence data center (>= 8.0.0 <= 8.0.4) • atlassian confluence data center (>= 8.1.0 <= 8.1.4) • atlassian confluence data center (>= 8.2.0 <= 8.2.3) • atlassian confluence data center (>= 8.3.0 <= 8.3.4) • atlassian confluence data center (>= 8.4.0 <= 8.4.5) • atlassian confluence data center (>= 8.5.0 <= 8.5.12) • atlassian confluence data center (>= 8.6.0 <= 8.6.2) • atlassian confluence data center (>= 8.7.1 <= 8.7.2) • atlassian confluence data center (>= 8.8.0 <= 8.8.1) • atlassian confluence data center (>= 8.9.0 <= 8.9.4) • atlassian confluence server (>= 7.19.0 <= 7.19.25) • atlassian confluence server (>= 7.20.0 <= 7.20.3) • atlassian confluence server (>= 8.0.0 <= 8.0.4) • atlassian confluence server (>= 8.1.0 <= 8.1.4) • atlassian confluence server (>= 8.2.0 <= 8.2.3) • atlassian confluence server (>= 8.3.0 <= 8.3.4) • atlassian confluence server (>= 8.4.0 <= 8.4.5) • atlassian confluence server (>= 8.5.0 <= 8.5.12) • atlassian confluence server (>= 8.6.0 <= 8.6.2) • atlassian confluence server (>= 8.7.1 <= 8.7.2) • atlassian confluence server (>= 8.8.0 <= 8.8.1) • atlassian confluence server (>= 8.9.0 <= 8.9.4)

Related

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References