CVEvulnerability
CVE-2024-21733
5.3 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2024-01-19
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 5.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-209
Description
Generation of Error Message Containing Sensitive Information vulnerability in Apache Tomcat.This issue affects Apache Tomcat: from 8.5.7 through 8.5.63, from 9.0.0-M11 through 9.0.43. Other, EOL versions may also be affected.
Users are recommended to upgrade to version 8.5.64 onwards or 9.0.44 onwards, which contain a fix for the issue.
Affected configurations
• apache tomcat (>= 8.5.7 < 8.5.64)
• apache tomcat (>= 9.0.1 < 9.0.44)
• apache tomcat 9.0.0
Related
Weakness · CWE (1)
- CWE-209 Generation of Error Message Containing Sensitive Information weakness
References
- https://lists.apache.org/thread/h9bjqdd0odj6lhs2o96qgowcc6hb0cfz Mailing List, Patch, Vendor Advisory
- http://packetstormsecurity.com/files/176951/Apache-Tomcat-8.5.63-9.0.43-HTTP-Response-Smuggling.html packetstormsecurity.com
- http://www.openwall.com/lists/oss-security/2024/01/19/2 Mailing List, Patch, Third Party Advisory
- https://lists.apache.org/thread/h9bjqdd0odj6lhs2o96qgowcc6hb0cfz Mailing List, Patch, Vendor Advisory
- https://lists.debian.org/debian-lts-announce/2025/01/msg00009.html lists.debian.org
- https://security.netapp.com/advisory/ntap-20240216-0005/ security.netapp.com