CVEvulnerability
CVE-2024-22188
7.2 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2024-03-05
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 7.2 HIGH — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-94
Description
TYPO3 before 13.0.1 allows an authenticated admin user (with system maintainer privileges) to execute arbitrary shell commands (with the privileges of the web server) via a command injection vulnerability in form fields of the Install Tool. The fixed versions are 8.7.57 ELTS, 9.5.46 ELTS, 10.4.43 ELTS, 11.5.35 LTS, 12.4.11 LTS, and 13.0.1.
Affected configurations
• typo3 typo3 (>= 8.0.0 < 8.7.57)
• typo3 typo3 (>= 9.0.0 < 9.5.46)
• typo3 typo3 (>= 10.0.0 < 10.4.43)
• typo3 typo3 (>= 11.0.0 < 11.5.35)
• typo3 typo3 (>= 12.0.0 < 12.4.11)
• typo3 typo3 13.0.0
Related
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness
References
- https://github.com/TYPO3/typo3/security/advisories/GHSA-5w2h-59j3-8x5w Vendor Advisory
- https://typo3.org/security/advisory/typo3-core-sa-2024-002 Vendor Advisory
- https://github.com/TYPO3/typo3/security/advisories/GHSA-5w2h-59j3-8x5w Vendor Advisory
- https://typo3.org/help/security-advisories Vendor Advisory
- https://typo3.org/security/advisory/typo3-core-sa-2024-002 Vendor Advisory