CVEvulnerability
CVE-2024-22212
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2024-01-18
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.6 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-306
Description
Nextcloud Global Site Selector is a tool which allows you to run multiple small Nextcloud instances and redirect users to the right server. A problem in the password verification method allows an attacker to authenticate as another user. It is recommended that the Nextcloud Global Site Selector is upgraded to version 1.4.1, 2.1.2, 2.3.4 or 2.4.5. There are no known workarounds for this issue.
Affected configurations
• nextcloud global site selector (>= 1.1.0 < 1.4.1)
• nextcloud global site selector (>= 2.0.0 < 2.1.2)
• nextcloud global site selector (>= 2.2.0 < 2.3.4)
• nextcloud global site selector (>= 2.4.0 < 2.4.5)
Related
Weakness · CWE (1)
- CWE-306 Missing Authentication for Critical Functionality weakness
References
- https://github.com/nextcloud/globalsiteselector/commit/ab5da57190d5bbc79079ce4109b6bcccccd893ee Patch
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-vj5q-f63m-wp77 Patch, Vendor Advisory
- https://hackerone.com/reports/2248689 Issue Tracking, Third Party Advisory
- https://github.com/nextcloud/globalsiteselector/commit/ab5da57190d5bbc79079ce4109b6bcccccd893ee Patch
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-vj5q-f63m-wp77 Patch, Vendor Advisory
- https://hackerone.com/reports/2248689 Issue Tracking, Third Party Advisory