CVEvulnerability
CVE-2024-22371
7.5 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2024-02-26
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 2.9 LOW — CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-922
Description
Exposure of sensitive data by by crafting a malicious EventFactory and providing a custom ExchangeCreatedEvent that exposes sensitive data. Vulnerability in Apache Camel.This issue affects Apache Camel: from 3.21.X through 3.21.3, from 3.22.X through 3.22.0, from 4.0.X through 4.0.3, from 4.X through 4.3.0.
Users are recommended to upgrade to version 3.21.4, 3.22.1, 4.0.4 or 4.4.0, which fixes the issue.
Affected configurations
• apache camel (>= 3.0.0 < 3.21.4)
• apache camel (>= 4.0.0 < 4.0.4)
• apache camel (>= 4.1.0 < 4.4.0)
• apache camel 3.22.0
Related
Weakness · CWE (1)
- CWE-922 Insecure Storage of Sensitive Information weakness
References
- https://camel.apache.org/security/CVE-2024-22371.html Vendor Advisory
- https://camel.apache.org/security/CVE-2024-22371.html Vendor Advisory