CVEvulnerability
CVE-2024-22400
6.1 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2024-01-18
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 3.1 LOW — CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:L/A:N
- CVSS 3.1 ([email protected])
- 6.1 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-601
Description
Nextcloud User Saml is an app for authenticating Nextcloud users using SAML. In affected versions users can be given a link to the Nextcloud server and end up on a uncontrolled thirdparty server. It is recommended that the User Saml app is upgraded to version 5.1.5, 5.2.5, or 6.0.1. There are no known workarounds for this issue.
Affected configurations
• nextcloud sso \& saml authentication (>= 5.0.0 < 5.1.5)
• nextcloud sso \& saml authentication (>= 5.2.0 < 5.2.5)
• nextcloud sso \& saml authentication 6.0.0
Related
Weakness · CWE (1)
- CWE-601 URL Redirection to Untrusted Site weakness
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-622q-xhfr-xmv7 Vendor Advisory
- https://github.com/nextcloud/user_saml/commit/b184304a476deeba36e92b70562d5de7c2f85f8a Patch
- https://github.com/nextcloud/user_saml/pull/788 Patch
- https://hackerone.com/reports/2263044 Permissions Required, Third Party Advisory
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-622q-xhfr-xmv7 Vendor Advisory
- https://github.com/nextcloud/user_saml/commit/b184304a476deeba36e92b70562d5de7c2f85f8a Patch
- https://github.com/nextcloud/user_saml/pull/788 Patch
- https://hackerone.com/reports/2263044 Permissions Required, Third Party Advisory