CVEvulnerability
CVE-2024-22403
3.7 LOW
Official page ↗
- Status
- Modified
- Published
- 2024-01-18
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 3.0 LOW — CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:N/A:N
- CVSS 3.1 ([email protected])
- 3.7 LOW — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-613
Description
Nextcloud server is a self hosted personal cloud system. In affected versions OAuth codes did not expire. When an attacker would get access to an authorization code they could authenticate at any time using the code. As of version 28.0.0 OAuth codes are invalidated after 10 minutes and will no longer be authenticated. To exploit this vulnerability an attacker would need to intercept an OAuth code from a user session. It is recommended that the Nextcloud Server is upgraded to 28.0.0. There are no known workarounds for this vulnerability.
Affected configurations
• nextcloud nextcloud server (< 28.0.0)
Related
Weakness · not in database (1)
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-wppc-f5g8-vx36 Vendor Advisory
- https://github.com/nextcloud/server/pull/40766 Patch, Vendor Advisory
- https://hackerone.com/reports/1784162 Permissions Required, Third Party Advisory
- https://lists.fedoraproject.org/archives/list/[email protected]/message/S6PN4GVJ5TZUC6WSG4X3ZA3AMPBEKNAX/ lists.fedoraproject.org
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-wppc-f5g8-vx36 Vendor Advisory
- https://github.com/nextcloud/server/pull/40766 Patch, Vendor Advisory
- https://hackerone.com/reports/1784162 Permissions Required, Third Party Advisory
- https://lists.fedoraproject.org/archives/list/[email protected]/message/S6PN4GVJ5TZUC6WSG4X3ZA3AMPBEKNAX/ lists.fedoraproject.org