CVEvulnerability

CVE-2024-23114

9.8 CRITICAL Published 2024-02-20 Modified 2026-06-17 Official page ↗
Status
Analyzed
Published
2024-02-20
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-502

Description

Deserialization of Untrusted Data vulnerability in Apache Camel CassandraQL Component AggregationRepository which is vulnerable to unsafe deserialization. Under specific conditions it is possible to deserialize malicious payload.This issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0. Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1

Affected configurations

• apache camel (>= 3.0.0 < 3.21.4) • apache camel (>= 4.0.0 < 4.0.4) • apache camel (>= 4.1.0 < 4.4.0) • apache camel 3.22.0

Related

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References