CVEvulnerability
CVE-2024-23321
8.8 HIGH
Official page ↗
- Status
- Modified
- Published
- 2024-07-22
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 7.5 HIGH — CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-200
Description
For RocketMQ versions 5.2.0 and below, under certain conditions, there is a risk of exposure of sensitive Information to an unauthorized actor even if RocketMQ is enabled with authentication and authorization functions.
An attacker, possessing regular user privileges or listed in the IP whitelist, could potentially acquire the administrator's account and password through specific interfaces. Such an action would grant them full control over RocketMQ, provided they have access to the broker IP address list.
To mitigate these security threats, it is strongly advised that users upgrade to version 5.3.0 or newer. Additionally, we recommend users to use RocketMQ ACL 2.0 instead of the original RocketMQ ACL when upgrading to version Apache RocketMQ 5.3.0.
Affected configurations
• apache rocketmq (>= 4.5.2 < 5.3.0)
Related
Weakness · CWE (1)
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness
References
- http://www.openwall.com/lists/oss-security/2024/07/22/1 Mailing List
- https://lists.apache.org/thread/lr8npobww786nrnddd1pcy974r17c830 Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2024/07/22/1 Mailing List
- https://lists.apache.org/thread/lr8npobww786nrnddd1pcy974r17c830 Mailing List, Vendor Advisory