CVEvulnerability

CVE-2024-23638

6.5 MEDIUM Published 2024-01-24 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2024-01-24
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
CVSS 3.1 ([email protected])
6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-672, CWE-825

Description

Squid is a caching proxy for the Web. Due to an expired pointer reference bug, Squid prior to version 6.6 is vulnerable to a Denial of Service attack against Cache Manager error responses. This problem allows a trusted client to perform Denial of Service when generating error pages for Client Manager reports. Squid older than 5.0.5 have not been tested and should be assumed to be vulnerable. All Squid-5.x up to and including 5.9 are vulnerable. All Squid-6.x up to and including 6.5 are vulnerable. This bug is fixed by Squid version 6.6. In addition, patches addressing this problem for the stable releases can be found in Squid's patch archives. As a workaround, prevent access to Cache Manager using Squid's main access control: `http_access deny manager`.

Affected configurations

• squid-cache squid (>= 5.0 <= 5.9) • squid-cache squid (>= 6.0 < 6.6)

Related

Weakness · CWE (2)

  • CWE-672 Operation on a Resource after Expiration or Release weakness
  • CWE-825 Expired Pointer Dereference weakness

References