CVEvulnerability

CVE-2024-24549

7.5 HIGH Published 2024-03-13 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2024-03-13
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-20

Description

Denial of Service due to improper input validation vulnerability for HTTP/2 requests in Apache Tomcat. When processing an HTTP/2 request, if the request exceeded any of the configured limits for headers, the associated HTTP/2 stream was not reset until after all of the headers had been processed.This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M16, from 10.1.0-M1 through 10.1.18, from 9.0.0-M1 through 9.0.85, from 8.5.0 through 8.5.98. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M17, 10.1.19, 9.0.86 or 8.5.99 which fix the issue.

Affected configurations

• apache tomcat (>= 8.5.0 < 8.5.99) • apache tomcat (>= 9.0.0 < 9.0.86) • apache tomcat (>= 10.1.0 < 10.1.19) • apache tomcat 11.0.0 • debian debian linux 10.0 • fedoraproject fedora 39 • fedoraproject fedora 40

Related

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References