CVEvulnerability

CVE-2024-24773

6.5 MEDIUM Published 2024-02-28 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2024-02-28
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
4.9 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
CVSS 3.1 ([email protected])
6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Weaknesses
CWE-863

Description

Improper parsing of nested SQL statements on SQLLab would allow authenticated users to surpass their data authorization scope. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1, which fixes the issue.

Affected configurations

• apache superset (< 3.0.4) • apache superset (>= 3.1.0 < 3.1.1)

Related

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References