CVEvulnerability
CVE-2024-24779
6.5 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2024-02-28
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.0 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-863
Description
Apache Superset with custom roles that include `can write on dataset` and without all data access permissions, allows for users to create virtual datasets to data they don't have access to. These users could then use those virtual datasets to get access to unauthorized data.
This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1.
Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.
Affected configurations
• apache superset (<= 3.0.4)
• apache superset (>= 3.1.0 < 3.1.1)
Related
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness
References
- http://www.openwall.com/lists/oss-security/2024/02/28/6 Mailing List, Third Party Advisory
- https://lists.apache.org/thread/xzhz1m5bb9zxhyqgoy4q2d689b3zp4pq Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2024/02/28/6 Mailing List, Third Party Advisory
- https://lists.apache.org/thread/xzhz1m5bb9zxhyqgoy4q2d689b3zp4pq Mailing List, Vendor Advisory