CVEvulnerability

CVE-2024-25141

9.1 CRITICAL Published 2024-02-20 Modified 2026-06-17 Official page ↗
Status
Analyzed
Published
2024-02-20
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-295

Description

When ssl was enabled for Mongo Hook, default settings included "allow_insecure" which caused that certificates were not validated. This was unexpected and undocumented. Users are recommended to upgrade to version 4.0.0, which fixes this issue.

Affected configurations

• apache apache-airflow-providers-mongo (>= 1.0.0 < 4.0.0)

Related

Weakness · CWE (1)

  • CWE-295 Improper Certificate Validation weakness

References