CVEvulnerability
CVE-2024-25723
8.8 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2024-02-27
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 8.8 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-284
Description
ZenML Server in the ZenML machine learning package before 0.46.7 for Python allows remote privilege escalation because the /api/v1/users/{user_name_or_id}/activate REST API endpoint allows access on the basis of a valid username along with a new password in the request body. These are also patched versions: 0.44.4, 0.43.1, and 0.42.2.
Affected configurations
• zenml zenml (< 0.42.2)
• zenml zenml (>= 0.44.0 < 0.44.4)
• zenml zenml (>= 0.45.0 < 0.46.7)
• zenml zenml 0.43.0
Related
Weakness · CWE (1)
- CWE-284 Improper Access Control weakness
References
- https://github.com/zenml-io/zenml Product
- https://github.com/zenml-io/zenml/compare/0.42.1...0.42.2 Product
- https://github.com/zenml-io/zenml/compare/0.43.0...0.43.1 Product
- https://github.com/zenml-io/zenml/compare/0.44.3...0.44.4 Product
- https://www.zenml.io/blog/critical-security-update-for-zenml-users Vendor Advisory
- https://github.com/zenml-io/zenml Product
- https://github.com/zenml-io/zenml/compare/0.42.1...0.42.2 Product
- https://github.com/zenml-io/zenml/compare/0.43.0...0.43.1 Product
- https://github.com/zenml-io/zenml/compare/0.44.3...0.44.4 Product
- https://www.zenml.io/blog/critical-security-update-for-zenml-users Vendor Advisory