CVEvulnerability
CVE-2024-26016
5.4 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2024-02-28
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 4.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- CVSS 3.1 ([email protected])
- 5.4 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- Weaknesses
- CWE-863
Description
A low privilege authenticated user could import an existing dashboard or chart that they do not have access to and then modify its metadata, thereby gaining ownership of the object. However, it's important to note that access to the analytical data of these charts and dashboards would still be subject to validation based on data access privileges.
This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1.Users are recommended to upgrade to version 3.1.1, which fixes the issue.
Affected configurations
• apache superset (< 3.0.4)
• apache superset (>= 3.1.0 < 3.1.1)
Related
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness
References
- http://www.openwall.com/lists/oss-security/2024/02/28/7 Mailing List, Third Party Advisory
- https://lists.apache.org/thread/76v1jjcylgk4p3m0258qr359ook3vl8s Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2024/02/28/7 Mailing List, Third Party Advisory
- https://lists.apache.org/thread/76v1jjcylgk4p3m0258qr359ook3vl8s Mailing List, Vendor Advisory