CVEvulnerability
CVE-2024-26580
9.1 CRITICAL
Official page ↗
- Status
- Analyzed
- Published
- 2024-03-06
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-502
Description
Deserialization of Untrusted Data vulnerability in Apache InLong.This issue affects Apache InLong: from 1.8.0 through 1.10.0, the attackers can
use the specific payload to read from an arbitrary file. Users are advised to upgrade to Apache InLong's 1.11.0 or cherry-pick [1] to solve it.
[1] https://github.com/apache/inlong/pull/9673
Affected configurations
• apache inlong (>= 1.4.0 < 1.11.0)
Related
Weakness · CWE (1)
- CWE-502 Deserialization of Untrusted Data weakness