CVEvulnerability

CVE-2024-27135

9.9 CRITICAL Published 2024-03-12 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2024-03-12
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
8.5 HIGH — CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
CVSS 3.1 ([email protected])
9.9 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Weaknesses
CWE-20, CWE-913

Description

Improper input validation in the Pulsar Function Worker allows a malicious authenticated user to execute arbitrary Java code on the Pulsar Function worker, outside of the sandboxes designated for running user-provided functions. This vulnerability also applies to the Pulsar Broker when it is configured with "functionsWorkerEnabled=true". This issue affects Apache Pulsar versions from 2.4.0 to 2.10.5, from 2.11.0 to 2.11.3, from 3.0.0 to 3.0.2, from 3.1.0 to 3.1.2, and 3.2.0. 2.10 Pulsar Function Worker users should upgrade to at least 2.10.6. 2.11 Pulsar Function Worker users should upgrade to at least 2.11.4. 3.0 Pulsar Function Worker users should upgrade to at least 3.0.3. 3.1 Pulsar Function Worker users should upgrade to at least 3.1.3. 3.2 Pulsar Function Worker users should upgrade to at least 3.2.1. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.

Affected configurations

• apache pulsar (>= 2.4.0 < 2.10.6) • apache pulsar (>= 2.11.0 < 2.11.4) • apache pulsar (>= 3.0.0 < 3.0.3) • apache pulsar (>= 3.1.0 < 3.1.3) • apache pulsar 3.2.0

Related

Weakness · CWE (2)

  • CWE-20 Improper Input Validation weakness
  • CWE-913 Improper Control of Dynamically-Managed Code Resources weakness

References