CVEvulnerability
CVE-2024-27137
5.3 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2025-02-04
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 5.3 MEDIUM — CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
- Weaknesses
- CWE-287
Description
In Apache Cassandra it is possible for a local attacker without access
to the Apache Cassandra process or configuration files to manipulate
the RMI registry to perform a man-in-the-middle attack and capture user
names and passwords used to access the JMX interface. The attacker can
then use these credentials to access the JMX interface and perform
unauthorized operations.
This is same vulnerability that CVE-2020-13946 was issued for, but the Java option was changed in JDK10.
This issue affects Apache Cassandra from 4.0.2 through 5.0.2 running Java 11.
Operators are recommended to upgrade to a release equal to or later than 4.0.15, 4.1.8, or 5.0.3 which fixes the issue.
Affected configurations
• apache cassandra (>= 4.0.2 < 4.0.15)
• apache cassandra (>= 4.1.0 < 4.1.8)
• apache cassandra (> 5.0.0 < 5.0.3)
• apache cassandra 5.0.0
Related
Weakness · CWE (1)
- CWE-287 Improper Authentication weakness
References
- https://lists.apache.org/thread/jsk87d9yv8r204mgqpz1qxtp5wcrpysm Issue Tracking, Mailing List, Vendor Advisory
- https://security.netapp.com/advisory/ntap-20250214-0004/ Third Party Advisory