CVEvulnerability
CVE-2024-27292
7.5 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2024-03-21
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-706
Description
Docassemble is an expert system for guided interviews and document assembly. The vulnerability allows attackers to gain unauthorized access to information on the system through URL manipulation. It affects versions 1.4.53 to 1.4.96. The vulnerability has been patched in version 1.4.97 of the master branch.
Affected configurations
• jhpyle docassemble (>= 1.4.53 < 1.4.97)
Related
Weakness · CWE (1)
- CWE-706 Use of Incorrectly-Resolved Name or Reference weakness
References
- https://github.com/jhpyle/docassemble/commit/97f77dc486a26a22ba804765bfd7058aabd600c9 Patch
- https://github.com/jhpyle/docassemble/security/advisories/GHSA-jq57-3w7p-vwvv Third Party Advisory
- https://github.com/jhpyle/docassemble/commit/97f77dc486a26a22ba804765bfd7058aabd600c9 Patch
- https://github.com/jhpyle/docassemble/security/advisories/GHSA-jq57-3w7p-vwvv Third Party Advisory