CVEvulnerability
CVE-2024-27906
5.9 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2024-02-29
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 5.9 MEDIUM — CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- Weaknesses
- CWE-862
Description
Apache Airflow, versions before 2.8.2, has a vulnerability that allows authenticated users to view DAG code and import errors of DAGs they do not have permission to view through the API and the UI.
Users of Apache Airflow are recommended to upgrade to version 2.8.2 or newer to mitigate the risk associated with this vulnerability
Affected configurations
• apache airflow (< 2.8.2)
Related
Weakness · CWE (1)
- CWE-862 Missing Authorization weakness
References
- https://github.com/apache/airflow/pull/37290 Broken Link
- https://github.com/apache/airflow/pull/37468 Issue Tracking
- https://lists.apache.org/thread/on4f7t5sqr3vfgp1pvkck79wv7mq9st5 Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2024/02/29/1 Mailing List
- https://github.com/apache/airflow/pull/37290 Broken Link
- https://github.com/apache/airflow/pull/37468 Issue Tracking
- https://lists.apache.org/thread/on4f7t5sqr3vfgp1pvkck79wv7mq9st5 Mailing List, Vendor Advisory