CVEvulnerability
CVE-2024-27915
8.1 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2024-03-06
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.8 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
- CVSS 3.1 ([email protected])
- 8.1 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-863
Description
Sulu is a PHP content management system. Starting in verson 2.2.0 and prior to version 2.4.17 and 2.5.13, access to pages is granted regardless of role permissions for webspaces which have a security system configured and permission check enabled. Webspaces without do not have this issue. The problem is patched in versions 2.4.17 and 2.5.13. Some workarounds are available. One may apply the patch to `vendor/symfony/security-http/HttpUtils.php` manually or avoid installing `symfony/security-http` versions greater equal than `v5.4.30` or `v6.3.6`.
Affected configurations
• sulu sulu (>= 2.2.0 < 2.4.17)
• sulu sulu (>= 2.5.0 < 2.5.13)
Related
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness
References
- https://github.com/sulu/sulu/commit/ec9c3f99e15336dc4f6877f512300f231c17c6da Patch
- https://github.com/sulu/sulu/security/advisories/GHSA-jr83-m233-gg6p Mitigation, Vendor Advisory
- https://github.com/sulu/sulu/commit/ec9c3f99e15336dc4f6877f512300f231c17c6da Patch
- https://github.com/sulu/sulu/security/advisories/GHSA-jr83-m233-gg6p Mitigation, Vendor Advisory