CVEvulnerability

CVE-2024-28098

5.4 MEDIUM Published 2024-03-12 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2024-03-12
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
6.4 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
CVSS 3.1 ([email protected])
5.4 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Weaknesses
CWE-863

Description

The vulnerability allows authenticated users with only produce or consume permissions to modify topic-level policies, such as retention, TTL, and offloading settings. These management operations should be restricted to users with the tenant admin role or super user role. This issue affects Apache Pulsar versions from 2.7.1 to 2.10.5, from 2.11.0 to 2.11.3, from 3.0.0 to 3.0.2, from 3.1.0 to 3.1.2, and 3.2.0. 2.10 Apache Pulsar users should upgrade to at least 2.10.6. 2.11 Apache Pulsar users should upgrade to at least 2.11.4. 3.0 Apache Pulsar users should upgrade to at least 3.0.3. 3.1 Apache Pulsar users should upgrade to at least 3.1.3. 3.2 Apache Pulsar users should upgrade to at least 3.2.1. Users operating versions prior to those listed above should upgrade to the aforementioned patched versions or newer versions.

Affected configurations

• apache pulsar (>= 2.7.1 < 2.10.6) • apache pulsar (>= 2.11.0 < 2.11.4) • apache pulsar (>= 3.0.0 < 3.0.3) • apache pulsar (>= 3.1.0 < 3.1.3) • apache pulsar 3.2.0

Related

Weakness · CWE (1)

  • CWE-863 Incorrect Authorization weakness

References