CVEvulnerability
CVE-2024-28108
6.1 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2024-03-25
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 4.7 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
- CVSS 3.1 ([email protected])
- 6.1 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79, CWE-80
Description
phpMyFAQ is an open source FAQ web application for PHP 8.1+ and MySQL, PostgreSQL and other databases. Due to insufficient validation on the `contentLink` parameter, it is possible for unauthenticated users to inject HTML code to the page which might affect other users. _Also, requires that adding new FAQs is allowed for guests and that the admin doesn't check the content of a newly added FAQ._ This vulnerability is fixed in 3.2.6.
Affected configurations
• phpmyfaq phpmyfaq 3.2.5
Related
References
- https://github.com/thorsten/phpMyFAQ/commit/4fed1d9602f0635260f789fe85995789d94d6634 Patch
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-48vw-jpf8-hwqh Exploit, Vendor Advisory
- https://github.com/thorsten/phpMyFAQ/commit/4fed1d9602f0635260f789fe85995789d94d6634 Patch
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-48vw-jpf8-hwqh Exploit, Vendor Advisory