CVEvulnerability
CVE-2024-28241
7.8 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2024-04-25
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.3 HIGH — CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 7.8 HIGH — CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-269
Description
The GLPI Agent is a generic management agent. Prior to version 1.7.2, a local user can modify GLPI-Agent code or used DLLs to modify agent logic and even gain higher privileges. Users should upgrade to GLPI-Agent 1.7.2 to receive a patch. As a workaround, use the default installation folder which involves installed folder is automatically secured by the system.
Affected configurations
• glpi-project glpi agent (< 1.7.2)
Related
Weakness · CWE (1)
- CWE-269 Improper Privilege Management weakness
References
- https://github.com/glpi-project/glpi-agent/commit/9a97114f595562c91b0833b4a800dd51e9df65e9 Patch
- https://github.com/glpi-project/glpi-agent/security/advisories/GHSA-3268-p58w-86hw Vendor Advisory
- https://github.com/glpi-project/glpi-agent/commit/9a97114f595562c91b0833b4a800dd51e9df65e9 Patch
- https://github.com/glpi-project/glpi-agent/security/advisories/GHSA-3268-p58w-86hw Vendor Advisory