CVEvulnerability

CVE-2024-28746

8.1 HIGH Published 2024-03-14 Modified 2026-06-17 Official page ↗
Status
Modified
Published
2024-03-14
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 ([email protected])
8.1 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
8.1 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Weaknesses
CWE-281

Description

Apache Airflow, versions 2.8.0 through 2.8.2, has a vulnerability that allows an authenticated user with limited permissions to access resources such as variables, connections, etc from the UI which they do not have permission to access.  Users of Apache Airflow are recommended to upgrade to version 2.8.3 or newer to mitigate the risk associated with this vulnerability

Affected configurations

• apache airflow (>= 2.8.0 < 2.8.3)

Related

Weakness · CWE (1)

  • CWE-281 Improper Preservation of Permissions weakness

References