CVEvulnerability
CVE-2024-29887
7.4 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2024-03-27
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.4 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- Weaknesses
- CWE-295
Description
Serverpod is an app and web server, built for the Flutter and Dart ecosystem. This bug bypassed the validation of TSL certificates on all none web HTTP clients in the `serverpod_client` package. Making them susceptible to a man in the middle attack against encrypted traffic between the client device and the server. An attacker would need to be able to intercept the traffic and highjack the connection to the server for this vulnerability to be used. Upgrading to version `1.2.6` resolves this issue.
Affected configurations
• serverpod serverpod (< 1.2.6)
Related
Weakness · CWE (1)
- CWE-295 Improper Certificate Validation weakness
References
- https://github.com/serverpod/serverpod/commit/d55bf8d12967fc7955a875cb3e0f9693bd6d2c71 Patch
- https://github.com/serverpod/serverpod/security/advisories/GHSA-h6x7-r5rg-x5fw Vendor Advisory
- https://github.com/serverpod/serverpod/commit/d55bf8d12967fc7955a875cb3e0f9693bd6d2c71 Patch
- https://github.com/serverpod/serverpod/security/advisories/GHSA-h6x7-r5rg-x5fw Vendor Advisory