CVEvulnerability
CVE-2024-30170
9.1 CRITICAL
Official page ↗
- Status
- Analyzed
- Published
- 2024-08-06
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.1 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-400
Description
PrivX before 34.0 allows data exfiltration and denial of service via the REST API. This is fixed in minor versions 33.1, 32.3, 31.3, and later, and in major version 34.0 and later,
Affected configurations
• ssh privx (>= 22.0 < 31.3)
• ssh privx (>= 32.0 < 32.3)
• ssh privx 33.0
Related
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness
References
- https://info.ssh.com/improper-input-validation-faq Exploit, Vendor Advisory
- https://privx.docs.ssh.com/docs/security Vendor Advisory