CVEvulnerability
CVE-2024-31452
9.8 CRITICAL
Official page ↗
- Status
- Analyzed
- Published
- 2024-04-16
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 8.1 HIGH — CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-863
Description
OpenFGA is a high-performance and flexible authorization/permission engine. Some end users of OpenFGA v1.5.0 or later are vulnerable to authorization bypass when calling Check or ListObjects APIs. You are very likely affected if your model involves exclusion (e.g. `a but not b`) or intersection (e.g. `a and b`). This vulnerability is fixed in v1.5.3.
Affected configurations
• openfga openfga (>= 1.5.0 < 1.5.3)
Related
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness
References
- https://github.com/openfga/openfga/commit/b6a6d99b2bdbf8c3781503989576076289f48ed2 Patch
- https://github.com/openfga/openfga/security/advisories/GHSA-8cph-m685-6v6r Patch, Vendor Advisory
- https://github.com/openfga/openfga/commit/b6a6d99b2bdbf8c3781503989576076289f48ed2 Patch
- https://github.com/openfga/openfga/security/advisories/GHSA-8cph-m685-6v6r Patch, Vendor Advisory