CVEvulnerability
CVE-2024-31860
6.5 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2024-04-09
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-22
Description
Improper Input Validation vulnerability in Apache Zeppelin.
By adding relative path indicators(E.g ..), attackers can see the contents for any files in the filesystem that the server account can access.
This issue affects Apache Zeppelin: from 0.9.0 before 0.11.0.
Users are recommended to upgrade to version 0.11.0, which fixes the issue.
Affected configurations
• apache zeppelin (>= 0.9.0 < 0.11.0)
Related
Weakness · CWE (1)
- CWE-22 Improper Limitation of a Pathname to a Restricted Directory weakness
References
- https://github.com/apache/zeppelin/pull/4632 Issue Tracking, Patch
- https://lists.apache.org/thread/c0zfjnow3oc3dzc8w5rbkzj8lqj5jm5x Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2024/04/09/2 Mailing List
- https://github.com/apache/zeppelin/pull/4632 Issue Tracking, Patch
- https://lists.apache.org/thread/c0zfjnow3oc3dzc8w5rbkzj8lqj5jm5x Mailing List, Vendor Advisory