CVEvulnerability

CVE-2024-31866

9.8 CRITICAL Published 2024-04-09 Modified 2026-06-17 Official page ↗
Status
Analyzed
Published
2024-04-09
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-116

Description

Improper Encoding or Escaping of Output vulnerability in Apache Zeppelin. The attackers can execute shell scripts or malicious code by overriding configuration like ZEPPELIN_INTP_CLASSPATH_OVERRIDES. This issue affects Apache Zeppelin: from 0.8.2 before 0.11.1. Users are recommended to upgrade to version 0.11.1, which fixes the issue.

Affected configurations

• apache zeppelin (>= 0.8.2 < 0.11.1)

Related

Weakness · CWE (1)

  • CWE-116 Improper Encoding or Escaping of Output weakness

References