CVEvulnerability
CVE-2024-32474
6.5 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2024-04-18
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.3 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
- CVSS 3.1 ([email protected])
- 6.5 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
- Weaknesses
- CWE-117, CWE-312
Description
Sentry is an error tracking and performance monitoring platform. Prior to 24.4.1, when authenticating as a superuser to Sentry with a username and password, the password is leaked as cleartext in logs under the _event_: `auth-index.validate_superuser`. An attacker with access to the log data could use these leaked credentials to login to the Sentry system as superuser. Self-hosted users on affected versions should upgrade to 24.4.1 or later. Users can configure the logging level to exclude logs of the `INFO` level and only generate logs for levels at `WARNING` or more.
Affected configurations
• sentry sentry (>= 24.3.0 < 24.4.1)
Related
References
- https://github.com/getsentry/sentry/commit/d5b34568d9f1c41362ccb62141532a0a2169512f Patch
- https://github.com/getsentry/sentry/pull/66393 Issue Tracking
- https://github.com/getsentry/sentry/pull/69148 Issue Tracking
- https://github.com/getsentry/sentry/security/advisories/GHSA-6cjm-4pxw-7xp9 Mitigation, Vendor Advisory
- https://github.com/getsentry/sentry/commit/d5b34568d9f1c41362ccb62141532a0a2169512f Patch
- https://github.com/getsentry/sentry/pull/66393 Issue Tracking
- https://github.com/getsentry/sentry/pull/69148 Issue Tracking
- https://github.com/getsentry/sentry/security/advisories/GHSA-6cjm-4pxw-7xp9 Mitigation, Vendor Advisory