CVEvulnerability
CVE-2024-32638
6.3 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2024-05-02
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 6.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- Weaknesses
- CWE-444
Description
Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') vulnerability in Apache APISIX when using `forward-auth` plugin.This issue affects Apache APISIX: from 3.8.0, 3.9.0.
Users are recommended to upgrade to version 3.8.1, 3.9.1 or higher, which fixes the issue.
Affected configurations
• apache apisix 3.8.0
• apache apisix 3.9.0
Related
Weakness · CWE (1)
- CWE-444 Inconsistent Interpretation of HTTP Requests weakness
References
- http://www.openwall.com/lists/oss-security/2024/05/02/2 Mailing List, Third Party Advisory
- https://lists.apache.org/thread/ngvgxllw4zn4hgngkqw2o225kf9wotov Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2024/05/02/2 Mailing List, Third Party Advisory
- https://lists.apache.org/thread/ngvgxllw4zn4hgngkqw2o225kf9wotov Mailing List, Vendor Advisory