CVEvulnerability
CVE-2024-3470
7.2 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2024-04-19
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.9 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:H/A:H
- CVSS 3.1 ([email protected])
- 7.2 HIGH — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-269
Description
An Improper Privilege Management vulnerability was identified in GitHub Enterprise Server that allowed an attacker to use a deploy key pertaining to an organization to bypass an organization ruleset. An attacker would require access to a valid deploy key for a repository in the organization as well as repository administrator access. This vulnerability affected versions of GitHub Enterprise Server 3.11 to 3.12 and was fixed in versions 3.11.8 and 3.12.2. This vulnerability was reported via the GitHub Bug Bounty program.
Affected configurations
• github enterprise server (>= 3.11.0 < 3.11.8)
• github enterprise server (>= 3.12.0 < 3.12.2)
Related
Weakness · CWE (1)
- CWE-269 Improper Privilege Management weakness
References
- https://docs.github.com/en/[email protected]/admin/release-notes#3.11.8 Release Notes
- https://docs.github.com/en/[email protected]/admin/release-notes#3.12.2 Release Notes
- https://docs.github.com/en/[email protected]/admin/release-notes#3.11.8 Release Notes
- https://docs.github.com/en/[email protected]/admin/release-notes#3.12.2 Release Notes