CVEvulnerability
CVE-2024-35164
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2025-07-02
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 6.8 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-129
Description
The terminal emulator of Apache Guacamole 1.5.5 and older does not properly validate console codes received from servers via text-based protocols like SSH. If a malicious user has access to a text-based connection, a specially-crafted sequence of console codes could allow arbitrary code to be executed
with the privileges of the running guacd process.
Users are recommended to upgrade to version 1.6.0, which fixes this issue.
Affected configurations
• apache guacamole (>= 0.8.0 < 1.6.0)
Related
Weakness · CWE (1)
- CWE-129 Improper Validation of Array Index weakness
References
- https://lists.apache.org/thread/sgs8lplbkrpvd3hrvcnnxh3028h4py70 Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2025/07/01/2 www.openwall.com