CVEvulnerability
CVE-2024-35227
7.5 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2024-07-03
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-20
Description
Discourse is an open-source discussion platform. Prior to version 3.2.3 on the `stable` branch and version 3.3.0.beta3 on the `tests-passed` branch, Oneboxing against a carefully crafted malicious URL can reduce the availability of a Discourse instance. The problem has been patched in version 3.2.3 on the `stable` branch and version 3.3.0.beta3 on the `tests-passed` branch. There are no known workarounds available for this vulnerability.
Affected configurations
• discourse discourse (<= 3.2.2)
Related
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://github.com/discourse/discourse/commit/10afe5fcf1ebf2e49cb80716d5e62e184c53519b Patch
- https://github.com/discourse/discourse/commit/6ce5673d2c1a511b602e1b2ade6cdc898d14ab36 Patch
- https://github.com/discourse/discourse/security/advisories/GHSA-664f-xwjw-752c Third Party Advisory
- https://github.com/discourse/discourse/commit/10afe5fcf1ebf2e49cb80716d5e62e184c53519b Patch
- https://github.com/discourse/discourse/commit/6ce5673d2c1a511b602e1b2ade6cdc898d14ab36 Patch
- https://github.com/discourse/discourse/security/advisories/GHSA-664f-xwjw-752c Third Party Advisory