CVEvulnerability
CVE-2024-35230
5.3 MEDIUM
Official page ↗
- Status
- Analyzed
- Published
- 2024-12-16
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 5.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- CVSS 3.1 ([email protected])
- 5.3 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-200
Description
GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. In affected versions the welcome and about page includes version and revision information about the software in use (including library and components used). This information is sensitive from a security point of view because it allows software used by the server to be easily identified. This issue has been patched in version 2.26.0 and all users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected configurations
• osgeo geoserver (>= 2.0.0 < 2.25.1)
Related
Weakness · CWE (1)
- CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness
References
- https://github.com/geoserver/geoserver/commit/74fdab745a5deff20ac99abca24d8695fe1a52f8 Patch
- https://github.com/geoserver/geoserver/commit/8cd1590a604a10875de67b04995f1952f631f920 Patch
- https://github.com/geoserver/geoserver/security/advisories/GHSA-6pfc-w86r-54q6 Exploit, Third Party Advisory
- https://github.com/geoserver/geoserver/security/advisories/GHSA-6pfc-w86r-54q6 Exploit, Third Party Advisory