CVEvulnerability
CVE-2024-35234
6.1 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2024-07-03
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 4.2 MEDIUM — CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:L
- CVSS 3.1 ([email protected])
- 6.1 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
Description
Discourse is an open-source discussion platform. Prior to version 3.2.3 on the `stable` branch and version 3.3.0.beta3 on the `tests-passed` branch, an attacker can execute arbitrary JavaScript on users’ browsers by posting a specific URL containing maliciously crafted meta tags. This issue only affects sites with Content Security Polic (CSP) disabled. The problem has been patched in version 3.2.3 on the `stable` branch and version 3.3.0.beta3 on the `tests-passed` branch. As a workaround, ensure CSP is enabled on the forum.
Affected configurations
• discourse discourse (< 3.2.3)
• discourse discourse (< 3.3.0)
• discourse discourse 3.3.0
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/discourse/discourse/commit/26aef0c288839378b9de5819e96eac8cf4ea60fd Patch
- https://github.com/discourse/discourse/commit/311b737c910cf0a69f61e1b8bc0b78374b6619d2 Patch
- https://github.com/discourse/discourse/security/advisories/GHSA-5chg-hm8c-wc58 Third Party Advisory
- https://github.com/discourse/discourse/commit/26aef0c288839378b9de5819e96eac8cf4ea60fd Patch
- https://github.com/discourse/discourse/commit/311b737c910cf0a69f61e1b8bc0b78374b6619d2 Patch
- https://github.com/discourse/discourse/security/advisories/GHSA-5chg-hm8c-wc58 Third Party Advisory