CVEvulnerability
CVE-2024-36268
9.8 CRITICAL
Official page ↗
- Status
- Modified
- Published
- 2024-08-02
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
- 7.6 HIGH — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:L
- Weaknesses
- CWE-94
Description
Improper Control of Generation of Code ('Code Injection') vulnerability in Apache InLong.
This issue affects Apache InLong: from 1.10.0 through 1.12.0, which could lead to Remote Code Execution. Users are advised to upgrade to Apache InLong's 1.13.0 or cherry-pick [1] to solve it.
[1] https://github.com/apache/inlong/pull/10251
Affected configurations
• apache inlong (>= 1.10.0 < 1.13.0)
Related
Weakness · CWE (1)
- CWE-94 Improper Control of Generation of Code weakness
References
- https://lists.apache.org/thread/1w1yp1bg5sjvn46dszkf00tz1vfs0frc Mailing List, Vendor Advisory
- http://www.openwall.com/lists/oss-security/2024/08/02/5 www.openwall.com