CVEvulnerability

CVE-2024-36522

9.8 CRITICAL Published 2024-07-12 Modified 2026-06-17 Official page ↗
Status
Analyzed
Published
2024-07-12
Last modified
2026-06-17
Assigner
[email protected]
CVSS 3.1 (134c704f-9b21-4f2e-91b3-4a467353bcc0)
9.8 CRITICAL — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-74

Description

The default configuration of XSLTResourceStream.java is vulnerable to remote code execution via XSLT injection when processing input from an untrusted source without validation. Users are recommended to upgrade to versions 10.1.0, 9.18.0 or 8.16.0, which fix this issue.

Affected configurations

• apache wicket (>= 8.0.0 < 8.16.0) • apache wicket (>= 9.0.0 < 9.18.0) • apache wicket 10.0.0

Related

Weakness · CWE (1)

  • CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness

References