CVEvulnerability
CVE-2024-37299
7.5 HIGH
Official page ↗
- Status
- Modified
- Published
- 2024-07-30
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 4.9 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:N/A:H
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-400
Description
Discourse is an open source discussion platform. Prior to 3.2.5 and 3.3.0.beta5, crafting requests to submit very long tag group names can reduce the availability of a Discourse instance. This vulnerability is fixed in 3.2.5 and 3.3.0.beta5.
Affected configurations
• discourse discourse (< 3.2.5)
• discourse discourse 3.3.0
Related
Weakness · CWE (1)
- CWE-400 Uncontrolled Resource Consumption weakness
References
- https://github.com/discourse/discourse/commit/188cb58daa833839c54c266ce22db150a3f3a210 Patch
- https://github.com/discourse/discourse/commit/76f06f6b1491db6bd09a4017d2c5591431b3b16e Patch
- https://github.com/discourse/discourse/security/advisories/GHSA-4j6h-9pjp-5476 Vendor Advisory
- https://github.com/discourse/discourse/commit/188cb58daa833839c54c266ce22db150a3f3a210 Patch
- https://github.com/discourse/discourse/commit/76f06f6b1491db6bd09a4017d2c5591431b3b16e Patch
- https://github.com/discourse/discourse/security/advisories/GHSA-4j6h-9pjp-5476 Vendor Advisory