CVEvulnerability
CVE-2024-3761
7.5 HIGH
Official page ↗
- Status
- Analyzed
- Published
- 2024-05-20
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 7.5 HIGH — CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- CVSS 3.0 ([email protected])
- 9.1 CRITICAL — CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
- Weaknesses
- CWE-862
Description
In lunary-ai/lunary version 1.2.2, the DELETE endpoint located at `packages/backend/src/api/v1/datasets` is vulnerable to unauthorized dataset deletion due to missing authorization and authentication mechanisms. This vulnerability allows any user, even those without a valid token, to delete a dataset by sending a DELETE request to the endpoint. The issue was fixed in version 1.2.8. The impact of this vulnerability is significant as it permits unauthorized users to delete datasets, potentially leading to data loss or disruption of service.
Affected configurations
• lunary lunary (< 1.2.8)
Related
Weakness · CWE (1)
- CWE-862 Missing Authorization weakness
References
- https://github.com/lunary-ai/lunary/commit/14078c1d2b8766075bf655f187ece24c7a787776 Patch
- https://huntr.com/bounties/e95fb0a0-e54a-4da8-a33d-ba858d0cec55 Exploit, Issue Tracking, Patch, Third Party Advisory
- https://github.com/lunary-ai/lunary/commit/14078c1d2b8766075bf655f187ece24c7a787776 Patch
- https://huntr.com/bounties/e95fb0a0-e54a-4da8-a33d-ba858d0cec55 Exploit, Issue Tracking, Patch, Third Party Advisory