CVEvulnerability
CVE-2024-37884
5.4 MEDIUM
Official page ↗
- Status
- Modified
- Published
- 2024-06-14
- Last modified
- 2026-06-17
- Assigner
- [email protected]
- CVSS 3.1 ([email protected])
- 3.5 LOW — CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L
- CVSS 3.1 ([email protected])
- 5.4 MEDIUM — CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L
- Weaknesses
- CWE-284
Description
Nextcloud Server is a self hosted personal cloud system. A malicious user was able to send delete requests for old versions of files they only got shared with read permissions. It is recommended that the Nextcloud Server is upgraded to 26.0.12 or 27.1.7 or 28.0.3 and that the Nextcloud Enterprise Server is upgraded to 26.0.12 or 27.1.7 or 28.0.3.
Affected configurations
• nextcloud nextcloud server (>= 25.0.0 < 25.0.13.7)
• nextcloud nextcloud server (>= 26.0.0 < 26.0.13)
• nextcloud nextcloud server (>= 27.0.0 < 27.1.8)
• nextcloud nextcloud server (>= 28.0.0 < 28.0.4)
Related
Weakness · CWE (1)
- CWE-284 Improper Access Control weakness
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-xwgx-f37p-xh8c Vendor Advisory
- https://github.com/nextcloud/server/pull/43727 Patch
- https://hackerone.com/reports/2290680 Issue Tracking
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-xwgx-f37p-xh8c Vendor Advisory
- https://github.com/nextcloud/server/pull/43727 Patch
- https://hackerone.com/reports/2290680 Issue Tracking